博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
HDOJ 1208 Pascal's Travels
阅读量:5266 次
发布时间:2019-06-14

本文共 2503 字,大约阅读时间需要 8 分钟。

Pascal's Travels

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1296    Accepted Submission(s): 570


Problem Description
An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress. 
Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed. 
HDOJ 1208 Pascal39;s Travels - qhn999 - 码代码的猿猿
Figure 1
HDOJ 1208 Pascal39;s Travels - qhn999 - 码代码的猿猿
Figure 2
 

Input
The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.
 

Output
The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board. 
 

Sample Input
4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1
 

Sample Output
3
0
7
Hint
Hint
Brute force methods examining every path will likely exceed the allotted time limit. 64-bit integer values are available as "__int64" values using the Visual C/C++ or "long long" values using GNU C/C++ or "int64" values using Free Pascal compilers.
 

Source
 

Recommend
mcqsmall
 
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int mp[40][40];
unsigned long long int dp[40][40];
int n;
int main()
{
while(scanf("%d",&n)!=EOF&&n!=-1)
{
    char str[40];
    for(int i=0;i<n;i++)
    {
        scanf("%s",str);
        for(int j=0;j<n;j++)
        {
            mp
[j]=str[j]-'0';
        }
    }
    memset(dp,0,sizeof(dp));
    int i,j;
    dp[0][0]=1;
    for(i=0;i<n;i++)
    {
        for(j=0;j<n;j++)
        {
            if(mp
[j]!=0)
            {
                if(i+mp
[j]<n)
                {
                    dp[i+mp
[j]][j]+=dp[j];
                }
                if(j+mp
[j]<n)
                {
                    dp
[j+mp[j]]+=dp[j];
                }
            }
        }
    }
    printf("%I64d\n",dp[n-1][n-1]);
}
    return 0;
}

转载于:https://www.cnblogs.com/CKboss/p/3350956.html

你可能感兴趣的文章
【洛谷P1816 忠诚】线段树
查看>>
电子眼抓拍大解密
查看>>
tomcat7的数据库连接池tomcatjdbc的25个优势
查看>>
Html 小插件5 百度搜索代码2
查看>>
java.io.IOException: read failed, socket might closed or timeout, read ret: -1
查看>>
java 常用命令
查看>>
卷积中的参数
查看>>
51nod1076 (边双连通)
查看>>
Linux pipe函数
查看>>
java equals 小记
查看>>
2019春 软件工程实践 助教总结
查看>>
Zerver是一个C#开发的Nginx+PHP+Mysql+memcached+redis绿色集成开发环境
查看>>
java实现哈弗曼树
查看>>
程序的静态链接,动态链接和装载 (补充)
查看>>
关于本博客说明
查看>>
python常用模块之sys, os, random
查看>>
HDU 2548 A strange lift
查看>>
Linux服务器在外地,如何用eclipse连接hdfs
查看>>
react双组件传值和传参
查看>>
[Kaggle] Sentiment Analysis on Movie Reviews
查看>>